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About this Document
This document covers some of Dreamweaver's advanced visual features that animate and enhance web pages.
You should already be familiar with html and both previous ATN Dreamweaver documents: Dreamweaver MX:
Introduction to Creating a Web Site and Dreamweaver MX: Defining Sites and Advanced Design.

Creating an Image Map
An image map is a single image that is subdivided into key invisible regions called "hot spots." You can assign
different links to each of these hot spots, or you can apply special formatting behaviors, which we will discuss be-
low.

To create an image map, insert an image into the document and select it. In the lower left corner of the image's
property inspector is a text field immediately after the word "Map." Enter a unique name for the image map (or
Dreamweaver will call it "Map" by default).

Select the appropriate shape for your hot spot by clicking on one of the buttons and dragging the mouse button
over an area on the image. You can make the hot spot a regular square, a regular circle, or an irregular freehand
polygon (when you work with the polygon tool, each click creates a vertex). You can use the drawing tools re-
peatedly. The hot spot will be covered in a blue mesh.
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Be careful not to let your hotspots overlap since web browsers will confuse the two. In some cases, the browser
will simply link both hotspots to the same file. In others, neither link will work. You can copy and paste hotspots
and treat them just like any other web page object.

To select one of the hotspots you have just drawn, use the arrow-like Pointer icon. When the hot spot is selected,
blue handles will appear around its perimeter. The hot spot Property Inspector will allow you to assign a link, a
target, and alternate text.

A good application of an image map is to create a navigation bar for your site. You can create a single image in a
program such as Photoshop and draw rectangular hot spots over the link options. As you will see below, you can
also apply interesting effects to the individual hot spots.

Behaviors
Behaviors provide interactivity in a web page. You have seen these effects when rolling the mouse over
something on a web page affected something else on that page.

A behavior is applied to an object, and is a combination of two events: a particular Action (such as a popup mes-
sage), and the Event that triggers that action (such as rolling the mouse over a spot). These are the most common
triggering Events:

• OnMouseOver: triggers the event when the user rolls the mouse over the object.

• OnMouseOut: triggers the event when the user rolls the mouse away from the object.

• OnClick: triggers the event when the user clicks on the object.

• OnLoad: triggers the event when the page is loaded into the browser.

When you perform one of these actions on an object that has been assigned a behavior, your Action calls a JavaS-
cript function that has been automatically added to the <HEAD> of your document.

Applying a Simple Behavior to an Image
This example demonstrates how to make a popup message appear when the user rolls the mouse over an image.

Insert an image into the document and select it.

Open the Behaviors Panel by selecting Window > Behaviors. The Behaviors Panel will appear in the panel group
on the right hand side of your screen. By default, Behaviors should be grouped with Design. Another way to ac-

Dreamweaver MX: Creating Interactive Websites Page: 2



cess the Behaviors panel, then, is to click on the downward pointing triangle next to Design and click on the Be-
haviors tab.

In the Behaviors panel, click on the + button. From the pop up menu, select Popup Message.

Within the behaviors panel, select the Event you just created from the list. A pulldown menu should appear. From
the pulldown menu, select OnMouseOver.

Note: You will see many of the same events repeated both with and without parentheses. You will have to experi-
ment because some of these work better with one browser than another. For example, Internet Explorer prefers
(OnClick) to OnClick. To be more specific with which browser or set of versions you prefer, choose Show Events
for at the bottom of the Events menu. When you select this option, you will have the ability to select the kind of
browser you'd like to be compatible with. Choosing earlier version browsers will ensure compatibility with almost
all users, but you'll have fewer Events from which to choose.

When your page is loaded into a browser, your popup message will appear whenever the user rolls the mouse over
the image in this example. Notice some of the other behaviors that are available:

• Check Browser, Check Plugin: allow your web page to check a visitor's computer for necessary configura-
tions. You can specify different pages to load dependent on, for example, whether your visitor uses Netscape or
has the Flash plugin.

• Go to URL: this is the same as making a link.

• Open Browser Window: this opens a new window. When you select this behavior, you can tell Dreamweaver
what URL to display in the new window.

• Play Sound: allows you to choose a sound file to play whenever an Event happens.

• Swap Image: this is the same as using a rollover in Insert > Interactive Image > Rollover Image (see below).

You cannot assign behaviors to plain text, but you can assign behaviors to linked text.
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Rollover Images
A rollover, easily one of the most popular visual effects on the internet, is an image that changes when you roll
the mouse over it. The effect is created when two images swap at just the right time. You can use the Behaviors
Panel to insert a rollover image, but there is a shortcut. Either select Insert > Interactive Images > Rollover Im-
age or click on the rollover image icon on the Common Tab of the Insert Bar.

You are prompted for a name that will refer to both images (any unique name will work) and are given two
Browse… buttons to navigate to the two image files you want to use.

Checking the option Preload Rollover Image will cause the images to be stored in the client browser's cache so
they will appear immediately when they need to. If you want to make the rollover image a link, you can also in-
sert a Uniform Resource Locator (URL) in the given field.

Interactive Layers

Layers allow you to have two objects occupying the same browser window space. They are excellent for absolute
positioning since you have complete control over where your text or images will be placed on the web page. Ima-
gine layers as sheets of transparent paper. You can write or draw on these sheets, and you can stack them and
move them around. You can even take them away temporarily if you want.

A number of exciting effects become available when you combine layers with JavaScript. For example, you could
have an online quiz, and you could reward correct answers with a picture that would suddenly appear by making
an invisible layer suddenly visible.

Inserting and Configuring Layers
To draw a layer on the page, select the Draw Layer icon on the Objects Panel, and drag the mouse over the rel-
evant region on your document.

Note: You will sometimes see a small shield-like icon appear on your web page.
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This is the Layer Anchor Point. You can move it wherever you like without harming your layer. You can also
make it appear or disappear by toggling View > Visual Aids > Invisible Elements.

To move or resize the layer, position the mouse over the rectangle in the upper left corner.

Although the simplest way to select the layer is by clicking on the rectangle in the upper left corner, other options
exist for when you have made your layer invisible or it is otherwise inaccessible. In these cases, choose the Layer
Anchor Point or open the Layer Window (Window > Others > Layers). The layer's Property Inspector will not
appear unless you have the entire layer selected; it will not show up if you only select the layer's content.

The Layer Property Inspector
The layer Property Inspector allows you to do the following:

• Choose a name for the layer. If you plan to manipulate the layer with JavaScript, a carefully chosen name will
help you because you will use that name when applying a behavior.

• Specify absolute pixel coordinates for the layer's location.

• Specify the layer's width and height.

• Define a z-index for the layer. A z-index tells the browser which layers go on top of which other layers. For ex-
ample, if you had three layers stacked on top of each other, the z-index of the lowest layer (closest to the page)
would be 1, and the z-index of the highest layer (the one closest to the viewer) would be 3.

• Set the visual property for the layer. Layers are visible by default. You can set this to "hidden" if you want the
layer to appear in response to some event.

• Set a background color or image.

Controlling Layers with Behaviors
To make your layers appear and disappear when the viewer rolls over some element or otherwise interacts with
your page, follow these steps:

1. Create a layer with a picture or some text in it.
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2. Set the layer's visibility property to "hidden."

3. Select the triggering image or link, and open the Behaviors panel.

4. Click on the + button and select Show-Hide Layers from the pop up menu.

5. Select the text layer, and click on the Show button. Click OK.

6. From the event pulldown menu in the Behaviors panel, select onMouseOver.

Putting Image Maps and Layers Together
Attractive and interesting pages can be created using a combination of image maps, layers, and behaviors. Ima-
gine an entire menu of options which becomes visible when the mouse rolls over a segment of the page. Create
this effect using the following steps:

1. Use a drawing program such as Photoshop to create a single image with all the main menu options printed on
it.

2. Draw appropriately shaped hot spots on the image. Assign URL links to each hot spot.

3. Draw all the submenus. Repeat steps 1 and 2 to assign links to each option.

4. Place all the submenus on strategically placed layers.

5. Set the visibility property of all the submenu layers to "hidden."

6. Assign behaviors to each of the hot spots so that when the mouse rolls over a hot spot, the appropriate layer
suddenly becomes visible.

Navigation Tools

Links work well enough for moving around your site and around the web, but Dreamweaver provides two tools
that make navigation more elegant and powerful: jump menus and flash buttons.

Jump Menus
Jump menus are pulldown menus that allow the user to select an internal or external document to visit. You can
put any display text you would like in the menu, and you can link to whatever URL(s) you specify.
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To create a jump menu: choose Insert > Form Object > Jump Menu.

Type the selection prompt (the text you would like to appear on the menu itself) in the Text field.

Type or browse to the URL to which you would like to jump. The Open URLs In option applies only if you are
working with several frames, in which case you can specify into which frame you would like the document to
open.

If you would like to have a "Go" button appear after the menu, check the appropriate box. Sometimes when you
use the "Go" button, the jump menu still ignores the "Go" button and opens the URL as soon as it's selected. To
make it work right, after you insert the jump menu into the page, select it, and from the Events panel select On-
Change and remove it.

To add more selections to the menu, click on the + button. Select - to remove a selection. The Property Inspector
for the jump menu allows you to change any of the selections.

Hint: The width of the pulldown menu is adjusted according to the widest selection in the list. If the menu looks
too narrow, enter a long line of hyphens as a selection (but do not apply a URL). You can also use a line of hy-
phens to separate sets of options.

Flash Buttons
Dreamweaver comes with a set of pre-constructed buttons so you do not have to go through the process of draw-
ing your own and assigning links and rollover images. These buttons were created in Flash, a graphics and anima-
tion program also made by Macromedia.
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This example button has three states and links wherever you like.

Some buttons are animated. You will have to experiment to find one you like.

To insert a Flash button:

1. Select Insert > Interactive Images > Flash button.

2. In the Style field you will see a list of all the buttons in the library. A preview is available at the top. If you roll
the mouse over the button, you will see a preview of its rollover effects.

3. Insert the text you would like to appear on the button in the Button Text field.

4. Specify the link, the target, the size, etc.
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Coming Up

By now, you have experimented with many of Dreamweaver's features for formatting and interactivity. We are
developing a fourth class to discuss issues like design, large site management, forms, user input, and templates.
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